RaspDac - MPD et Bitperfect

Ici on parle de Raspberry PI, Sparky, Odroid... avec des solutions comme Squeezelite, MPD, Max2Play... ainsi que leur DAC et accessoires dédiés
All4linux
Messages : 35
Inscription : sam. 09 avr. 2016 08:30

RaspDac - MPD et Bitperfect

Message par All4linux » mar. 12 avr. 2016 06:55

Bonjour,

J'avais dans une autre époque pas mal réfléchi sur le moyen d'avoir un son qui n'était pas remixer ou modifier par un quelconque logiciel. J'utilisais MPD et je souhaitais pouvoir transmettre le son sans modification par un quelconque mixer de celui-ci.
Si cela vous intéresse et les retours seront intéressant quand à la différence d'écoute (moi j'en ai trouvé clairement une), je vous donne le paramètre de mon mpd.conf

Tout d'abord connectez-vous avec putty sur votre Volumio

Ensuite renommer votre mpd.conf actuel par mpd.old

Ensuite créer un nouveau mpd.conf avec les paramètres suivants :

sudo nano mpd.conf
###################################
# Auto generated mpd.conf file
# please DO NOT edit it manually!
# Use player-UI MPD config section
###################################

follow_outside_symlinks "yes"
follow_inside_symlinks "yes"
db_file "/var/lib/mpd/tag_cache"
sticker_file "/var/lib/mpd/sticker.sql"
log_file "/var/log/mpd/mpd.log"
pid_file "/var/run/mpd/pid"
music_directory "/var/lib/mpd/music"
playlist_directory "/var/lib/mpd/playlists"
state_file "/var/lib/mpd/state"
user "mpd"
bind_to_address "any"
port "6600"
zeroconf_enabled "no"
zeroconf_name "volumio"
filesystem_charset "UTF-8"
id3v1_encoding "UTF-8"
gapless_mp3_playback "yes"
auto_update "no"
group "audio"
max_connections "20"



audio_output {

type "alsa"
name "Output"
device "hw:0,0"
mixer_device "hw:0"
mixer_index "0"
dop "no"
auto_resample "no"
auto_channels "no"
auto_format "no"

}
redémarrer le mpd avec la commande sudo /etc/init.d/mpd restart et le tour est joué.

Mettez vos retours d'écoute.

Bonne journée.

Avatar de l’utilisateur
Nicko
Administrateur - Site Admin
Messages : 448
Inscription : mer. 26 juil. 2006 12:21
Localisation : Bordeaux
Contact :

Re: RaspDac - MPD et Bitperfect

Message par Nicko » ven. 15 avr. 2016 16:52

Merci All4linux,
Est-ce que ce sont ces paramètres qui font que ce paramétrage est bit perfect ?

Code : Tout sélectionner

dop "no"
auto_resample "no"
auto_channels "no"
auto_format "no"

Avatar de l’utilisateur
Cram28
Messages : 62
Inscription : dim. 29 nov. 2015 13:41

Re: RaspDac - MPD et Bitperfect

Message par Cram28 » ven. 15 avr. 2016 17:16

Tiens, j'avais pas vu !

Je vais essayé, pour voir ... écouter !

C'est bien le fichier ''/etc/mpd.conf'' ?
C'est quoi que tu modifies par rapport à l'original ?

Merci.

All4linux
Messages : 35
Inscription : sam. 09 avr. 2016 08:30

Re: RaspDac - MPD et Bitperfect

Message par All4linux » ven. 15 avr. 2016 17:24

Cram28,

Edit ton /etc/mpd.conf sur ton image actuel tu verras la différence, il faut surtout pas ré-encoder et resample ;-)

la différence de son est flagrante !

Bye

Avatar de l’utilisateur
rikardo1979
Messages : 160
Inscription : sam. 09 avr. 2016 08:39
Localisation : UK
Contact :

Re: RaspDac - MPD et Bitperfect

Message par rikardo1979 » dim. 17 avr. 2016 09:20

All4linux a écrit :Bonjour,

J'avais dans une autre époque pas mal réfléchi sur le moyen d'avoir un son qui n'était pas remixer ou modifier par un quelconque logiciel. J'utilisais MPD et je souhaitais pouvoir transmettre le son sans modification par un quelconque mixer de celui-ci.
Si cela vous intéresse et les retours seront intéressant quand à la différence d'écoute (moi j'en ai trouvé clairement une), je vous donne le paramètre de mon mpd.conf

Tout d'abord connectez-vous avec putty sur votre Volumio

Ensuite renommer votre mpd.conf actuel par mpd.old

Ensuite créer un nouveau mpd.conf avec les paramètres suivants :

sudo nano mpd.conf
###################################
# Auto generated mpd.conf file
# please DO NOT edit it manually!
# Use player-UI MPD config section
###################################

follow_outside_symlinks "yes"
follow_inside_symlinks "yes"
db_file "/var/lib/mpd/tag_cache"
sticker_file "/var/lib/mpd/sticker.sql"
log_file "/var/log/mpd/mpd.log"
pid_file "/var/run/mpd/pid"
music_directory "/var/lib/mpd/music"
playlist_directory "/var/lib/mpd/playlists"
state_file "/var/lib/mpd/state"
user "mpd"
bind_to_address "any"
port "6600"
zeroconf_enabled "no"
zeroconf_name "volumio"
filesystem_charset "UTF-8"
id3v1_encoding "UTF-8"
gapless_mp3_playback "yes"
auto_update "no"
group "audio"
max_connections "20"



audio_output {

type "alsa"
name "Output"
device "hw:0,0"
mixer_device "hw:0"
mixer_index "0"
dop "no"
auto_resample "no"
auto_channels "no"
auto_format "no"

}
redémarrer le mpd avec la commande sudo /etc/init.d/mpd restart et le tour est joué.

Mettez vos retours d'écoute.

Bonne journée.
thank you for this
~~~~>>>Please always follow rules and read before you post<<<~~~~

Répondre