Moode Audio support

Ici on parle de Raspberry PI, Sparky, Odroid... avec des solutions comme Squeezelite, MPD, Max2Play... ainsi que leur DAC et accessoires dédiés
Avatar de l’utilisateur
Audiophonics
Messages : 1128
Inscription : lun. 24 janv. 2011 12:55

Re: Moode Audio support?

Message par Audiophonics » ven. 26 août 2016 09:37

rikardo1979 a écrit :I have tried and messed around with attention to get OLED running on MoodeAudio.
But as I am pretty useless with code it wasn't an success unfortunately.

Anyone else tried and using MoodeAudio and tried or have display working?

I have done multiple audio tests and MoodeAudio is still the best out there. So I will keep this for my RaspDAC for sure as audio qulity is the most important to me, even the display does not work.
But it would be nice to have it working.
Hi Rikardo,

You can find here a modded Drone With power managment support and another one with power management and Oled support :
"Vous pouvez trouver ici une version modée de Moode Audio intégrant la gestion de l'alimentation ainsi qu'une autre gérant la gestion de l'alimentation et l'afficheur Oled"

PW management :
"Gestion de l'alimentation":

https://mega.nz/#!8AwHECpT!PHMOpwo7sBqI ... DPikfDU2Dk

PW management + Oled Display :
"Gestion de l'alimentation et afficheur Oled"

https://mega.nz/#!kYwWBAxS!35kR-cV3dRWi ... GI_dYUUx0A

Please give us a feedback.
"n'hésitez pas à nous faire part de votre retour"
David

Avatar de l’utilisateur
rikardo1979
Messages : 160
Inscription : sam. 09 avr. 2016 08:39
Localisation : UK
Contact :

Re: Moode Audio support?

Message par rikardo1979 » ven. 26 août 2016 11:09

Audiophonics a écrit :
rikardo1979 a écrit :I have tried and messed around with attention to get OLED running on MoodeAudio.
But as I am pretty useless with code it wasn't an success unfortunately.

Anyone else tried and using MoodeAudio and tried or have display working?

I have done multiple audio tests and MoodeAudio is still the best out there. So I will keep this for my RaspDAC for sure as audio qulity is the most important to me, even the display does not work.
But it would be nice to have it working.
Hi Rikardo,

You can find here a modded Drone With power managment support and another one with power management and Oled support :
"Vous pouvez trouver ici une version modée de Moode Audio intégrant la gestion de l'alimentation ainsi qu'une autre gérant la gestion de l'alimentation et l'afficheur Oled"

PW management :
"Gestion de l'alimentation":

https://mega.nz/#!8AwHECpT!PHMOpwo7sBqI ... DPikfDU2Dk

PW management + Oled Display :
"Gestion de l'alimentation et afficheur Oled"

https://mega.nz/#!kYwWBAxS!35kR-cV3dRWi ... GI_dYUUx0A

Please give us a feedback.
"n'hésitez pas à nous faire part de votre retour"
This is a great news :) Thank you for your hard work
Will definitely test it tonioght and post back here ;)

thx guys
~~~~>>>Please always follow rules and read before you post<<<~~~~

morias
Messages : 22
Inscription : lun. 15 août 2016 03:29

Re: Moode Audio support?

Message par morias » dim. 28 août 2016 07:08

I have tried it and it works fine. Thanks a lot for creating it. Would it be possible to get a guide on how to do it as Moode gets updated every other week and it would be good to stay updated. Version 2.7 is meant to have some major upgrades to mpd.

Avatar de l’utilisateur
rikardo1979
Messages : 160
Inscription : sam. 09 avr. 2016 08:39
Localisation : UK
Contact :

Re: Moode Audio support?

Message par rikardo1979 » mar. 30 août 2016 07:40

morias a écrit :I have tried it and it works fine. Thanks a lot for creating it. Would it be possible to get a guide on how to do it as Moode gets updated every other week and it would be good to stay updated. Version 2.7 is meant to have some major upgrades to mpd.
+1 for this

It would be great to have step by step How-To (preferably in english :D) so than we can adapt systems when needed ;)
Hope you can help us guys
Thanks in advance
~~~~>>>Please always follow rules and read before you post<<<~~~~

morias
Messages : 22
Inscription : lun. 15 août 2016 03:29

Re: Moode Audio support?

Message par morias » sam. 03 sept. 2016 13:45

I built a Moode 2.7 image. I built it by emulating the 2.6 image then following the Volumio instructions from Dhrone.

Also had to use the files in /home/pi and /var/www/command/scripts and then modify /etc/rc.local and /var/www/command/worker.php

lemting
Messages : 17
Inscription : ven. 05 août 2016 12:40

Re: Moode Audio support?

Message par lemting » sam. 03 sept. 2016 16:24

morias a écrit :I built a Moode 2.7 image. I built it by emulating the 2.6 image then following the Volumio instructions from Dhrone.

Also had to use the files in /home/pi and /var/www/command/scripts and then modify /etc/rc.local and /var/www/command/worker.php
you did it for power and screen or just power?

morias
Messages : 22
Inscription : lun. 15 août 2016 03:29

Re: Moode Audio support?

Message par morias » sam. 03 sept. 2016 23:11

It works with both power and screen. I just copied what Audiophonics did with their 2.6 image.

Audiophonics may have compiled a new gpio but it was already installed in Moode in /usr/local/bin so I just used that one.

morias
Messages : 22
Inscription : lun. 15 août 2016 03:29

Re: Moode Audio support?

Message par morias » dim. 04 sept. 2016 12:34

I have written these instructions to set up Moode. Thanks go to Tim Curtis for his wonderful distribution. I am not good with formatting the instructions so perhaps someone better than me could do this in another post. Hope I haven't made any typos as it works for me.

Step 1 - Write image

Download Moode 2.7 and write it to your sdcard based on your preferred method.

Step 2 - Boot and login

Boot Moode and ssh into it as follows:

ssh pi@moode.local
password: raspberry

Step 3 - Get the files for the display

I didn't work this out. Thanks go to Dhrone and his Github page:

https://github.com/dhrone/Raspdac-Display" onclick="window.open(this.href);return false;

To get the display going run these commands:

wget https://raw.githubusercontent.com/dhron ... Display.py" onclick="window.open(this.href);return false;
wget https://raw.githubusercontent.com/dhron ... hicOLED.py" onclick="window.open(this.href);return false;

You also need a pages.py. Either download from dhrone or use mine below.

wget https://www.dropbox.com/s/x8c1zn2rn9tfupf/pages.py" onclick="window.open(this.href);return false;

If you use my pages, also use my version of RaspDacDisplay.py For some reason, the latest one isn't working with my pages.py

wget https://www.dropbox.com/s/hvwtv75n1odys ... Display.py" onclick="window.open(this.href);return false;

I then edit RaspDacDisplay.py to have my local timezone and change the animation speed from .08 to .24 in the 2 places it appears. I normally then set song title to about 24 seconds and artist to 4 seconds. Now going on:

sudo apt-get update
sudo apt-get install python-setuptools
sudo easy_install pip
sudo pip install moment
sudo pip install pylms
sudo pip install python-mpd2

Step 4 - Setup the power button scripts

cd /var/www/command/
sudo mkdir scripts
cd scripts
sudo nano power_button

Now add the following text:

#!/bin/bash

PATH=/bin:/usr/bin:/usr/bin/gpio

echo "Audiophonics Shutdown script starting..."
echo "Asserting pins : "
echo "ShutDown : GPIO17=in, Low"
echo "BootOK : GPIO22=out, High"

gpio -g mode 17 in
gpio -g write 17 0
gpio -g mode 22 out
gpio -g write 22 1

while [ 1 ]; do
if [ "$(/usr/bin/gpio -g read 17)" = "1" ]; then
echo "ShutDown order received, RaspBerry pi will now enter in standby mode..."
systemctl poweroff
break
fi
/bin/sleep 0.25
done

exit 0

Save that file then keep going.

sudo nano power_manager

Now add the following text:

#!/bin/bash

if [[ $1 == "poweroff" ]]
then
echo "power off RuneAudio"
gpio mode 7 out
gpio write 7 1
sleep 1
echo "Setting pin GPIO7 Low"
gpio write 7 0
else
echo "reboot RuneAudio"
# Reboot blink will stop after Boot OK return
echo "setting pin GPIO 4 High"
gpio -g mode 4 out
gpio -g write 4 1
fi

echo "Stop MPD and unmount shares..."

mpc stop
sudo systemctl stop nginx
sleep 0.5
sudo systemctl stop mpd

Save that file and keep going.

Make them executable by running:

sudo chmod +x *

Step 5 - Make sure gpio is where the scripts expect it

cd /usr/bin/
sudo cp /usr/local/bin/gpio .

Step 6 - Fix restart.sh to run the power button scripts

cd /var/www/command/
sudo nano restart.sh

In the reboot command, add the following line after "systemctl stop nginx":

/var/www/command/scripts/power_manager

In the poweroff command, add the following line after "systemctl stop nginx":

/var/www/command/scripts/power_manager poweroff

Step 7 - Fix rc.local

cd /etc
sudo nano rc.local

Now add the following text to the bottom before exit 0:

/var/www/command/scripts/power_button &
(sleep 20; sudo python /home/pi/RaspDacDisplay.py) &

Save the file and exit.

Now reboot. Good luck.
Dernière modification par morias le dim. 11 déc. 2016 08:33, modifié 7 fois.

Marcellom
Messages : 14
Inscription : ven. 20 nov. 2015 19:29

Re: Moode Audio support?

Message par Marcellom » mar. 13 sept. 2016 07:31

Hi to all.
Finally i've tried the Morias tutorial and is great, all works.
But randomly happens that my display starts to visualize random characters.
This is a little video
https://youtu.be/QmvXF9TArrM" onclick="window.open(this.href);return false;
The problem occurs frequently in the start screen , rarely during the execution of the tracks.
I have AUDIOPHONICS Raspdac with RPI2 and I-Sabre DAC ES9023 V2 TCXO.
I dont think it is a wiring problem because it was mounted by Audiophonics technicians.
Anyone have the same problem? Solutions?

morias
Messages : 22
Inscription : lun. 15 août 2016 03:29

Re: Moode Audio support?

Message par morias » mar. 13 sept. 2016 13:34

Sorry, I can't help you with the random characters. Perhaps Audiophonics can suggest what is happening. For what it's worth, I have the V3 dac, not the V2 that you are using.

dhrone
Messages : 39
Inscription : sam. 27 févr. 2016 20:51

Re: Moode Audio support?

Message par dhrone » mar. 13 sept. 2016 17:53

@morias,

I've been trying to track down what causes this bug for a long time. It is very intermittent on my system to the point that I can go for weeks without it occurring. It sounds like on your system, it is much more frequent. If you can figure out any patterns or triggering activities that can consistently cause it to occur, please let me know.

Also, it would be good to know from other users whether they are experiencing any display corruptions and how frequently.

Thanks,
Dhrone

Marcellom
Messages : 14
Inscription : ven. 20 nov. 2015 19:29

Re: Moode Audio support?

Message par Marcellom » mar. 13 sept. 2016 18:16

First, thanks Dhrone...great work, im happy with your script in my raspdac!!!!
Second:
I cant believe!
For one year , random , I had the problem of random characters that appeared .... accidentally.
With Moode installed the problem had become systematic.
On every start, after few seconds...the screen starts with nosense characters.
Now i think I've solved!
How???
Reading this thread
viewtopic.php?f=4&t=1492" onclick="window.open(this.href);return false;
about raspdac and OLED, Cram28 , that i thank so much , had the same problem and found double-checking the wiring that was missing a wire bridge between pin 1 and pin 5 of the OLED Winstar .
I do not think I had the same problem because my raspdac arrived already assembled by Audiophonics technicians ... and yet , my little black monster was not wired at those points (pin 1 and 5 from Oled screen must go to GND pin 6 of the raspberry).
So I took my iron and soldered the wire , as in the diagram ATTACHED .
Amazing ....my raspdac is working about 2 hours without problems!
Hopefully continue so..
Let my say...im happy :-D :-D :-D :-D :-D :-D
Pièces jointes
WIRING.jpg
WIRING.jpg (74.86 Kio) Consulté 19937 fois

dhrone
Messages : 39
Inscription : sam. 27 févr. 2016 20:51

Re: Moode Audio support?

Message par dhrone » mer. 14 sept. 2016 18:49

I'm really glad to hear that you resolved your problem. I've got a second RaspDac that I use for development. It recently started exhibiting problems and I also found that it was a grounding problem. Looks like something that should be highlighted in the installation instructions.

Marcellom
Messages : 14
Inscription : ven. 20 nov. 2015 19:29

Re: Moode Audio support?

Message par Marcellom » jeu. 15 sept. 2016 07:02

Thank you Dhrone :)
Yes, it is easy to forget that bridge , obviously .
However i agree: the problem is finally resolved, after more than 24 hours the raspdac works like a charm.
:)

Avatar de l’utilisateur
rikardo1979
Messages : 160
Inscription : sam. 09 avr. 2016 08:39
Localisation : UK
Contact :

Re: Moode Audio support?

Message par rikardo1979 » jeu. 22 sept. 2016 11:24

I just wondering what is happening with official step by step Howto guide from Audiophonics?
8) :roll:
~~~~>>>Please always follow rules and read before you post<<<~~~~

Avatar de l’utilisateur
rikardo1979
Messages : 160
Inscription : sam. 09 avr. 2016 08:39
Localisation : UK
Contact :

Re: Moode Audio support?

Message par rikardo1979 » sam. 22 oct. 2016 16:13

so Mo0de has been updated few times since and other systems too and we still dont have a proper step by step guide how to do all the scripts...
:evil: :cry:
~~~~>>>Please always follow rules and read before you post<<<~~~~

Avatar de l’utilisateur
Conseil Audiophonics
Messages : 143
Inscription : ven. 19 août 2016 08:35
Contact :

Re: Moode Audio support?

Message par Conseil Audiophonics » mer. 26 oct. 2016 10:28

Hello,

You will find on this link the last image of MoodAudio, with LCD and Power Management : https://mega.nz/#!BBByiL7K!nEXjBKfVaS8l ... S_5GYpAbFI" onclick="window.open(this.href);return false;

Good installation :)
Cordialement,
L'équipe Audiophonics.fr

Avatar de l’utilisateur
rikardo1979
Messages : 160
Inscription : sam. 09 avr. 2016 08:39
Localisation : UK
Contact :

Re: Moode Audio support?

Message par rikardo1979 » mer. 26 oct. 2016 11:59

Conseil Audiophonics a écrit :Hello,

You will find on this link the last image of MoodAudio, with LCD and Power Management : https://mega.nz/#!BBByiL7K!nEXjBKfVaS8l ... S_5GYpAbFI" onclick="window.open(this.href);return false;

Good installation :)
very nice. Thanks
Hope you can make the how to procedure before Moode 3.0 is out ;) which should be very soon
~~~~>>>Please always follow rules and read before you post<<<~~~~

Avatar de l’utilisateur
Conseil Audiophonics
Messages : 143
Inscription : ven. 19 août 2016 08:35
Contact :

Re: Moode Audio support?

Message par Conseil Audiophonics » mer. 26 oct. 2016 14:42

After the complete image of MoodAudio : https://mega.nz/#!BBByiL7K!nEXjBKfVaS8l ... S_5GYpAbFI" onclick="window.open(this.href);return false;

The procedure :

Part 1 :
Install the libs for the Oled and PWR Manager:

Code : Tout sélectionner

sudo apt-get install python-setuptools
sudo easy_install pip
sudo pip install moment && sudo pip install pylms && sudo pip install python-mpd2
sudo apt-get install wiringPi
Part 2 :
Download scripts for MoodeAudio:

Code : Tout sélectionner

git clone https://github.com/audiophonics/MoodAudio-RaspDAC-Script
Part 3 :
Make the scripts executable:

Code : Tout sélectionner

chmod 755 /home/pi/MoodAudio-RaspDAC-Script/*.sh
Part 4 :
Open the rc.local file:

Code : Tout sélectionner

sudo nano /etc/rc.local
Part 5 :
Add this two lines before the exit 0:
/home/pi/MoodAudio-RaspDAC-Script/sds.sh &
(sleep 20; sudo python /home/pi/MoodAudio-RaspDAC-Script/RaspDacDisplay.py) &

Part 6 :
Open the restart.sh file:

Code : Tout sélectionner

sudo nano /var/www/command/restart.sh
Part 7 :
Replace reboot by:
exec "/home/pi/MoodAudio-RaspDAC-Script/softreboot.sh"

Part 8 :
Replace shutdown by:
exec "/home/pi/MoodAudio-RaspDAC-Script/softshutdown.sh"
Dernière modification par Conseil Audiophonics le lun. 14 nov. 2016 12:05, modifié 2 fois.
Cordialement,
L'équipe Audiophonics.fr

Avatar de l’utilisateur
rikardo1979
Messages : 160
Inscription : sam. 09 avr. 2016 08:39
Localisation : UK
Contact :

Re: Moode Audio support?

Message par rikardo1979 » mer. 26 oct. 2016 18:46

Conseil Audiophonics a écrit :After the complete image of MoodAudio : https://mega.nz/#!BBByiL7K!nEXjBKfVaS8l ... S_5GYpAbFI" onclick="window.open(this.href);return false;

The procedure :

Part 1 :
Install the libs for the Oled and PWR Manager:

Code : Tout sélectionner

sudo apt-get install python-setuptools
sudo easy_install pip
sudo pip install moment && sudo pip install pylms && sudo pip install python-mpd2
sudo apt-get install wiringPi
Part 2 :
Download scripts for MoodeAudio:

Code : Tout sélectionner

wget https://mega.nz/#!Ichl1LoL!JPlu2MQJn2l423KVAbHTEOoiIYm99MoXt7ZV-aS061I
Part 3 :
Untar the tarboll:

Code : Tout sélectionner

tar xvf Moodeaudio_Audiophonics_scripts.tar
Part 4 :
Make the scripts executable:

Code : Tout sélectionner

chmod 755 /home/pi/audiophonics/*.sh
Part 5 :
Open the rc.local file:

Code : Tout sélectionner

sudo nano /etc/rc.local
Part 6 :
Add this two lines before the exit 0:
/home/pi/audiophonics/sds.sh &
(sleep 20; sudo python /home/pi/audiophonics/RaspDacDisplay.py) &

Part 7 :
Open the restart.sh file:

Code : Tout sélectionner

sudo nano /var/www/commande/restart.sh
Part 8 :
Replace reboot by:
exec "/home/pi/audiophonics/softreboot.sh"

Part 9 :
Replace shutdown by:
exec "/home/pi/audiophonics/softshutdown.sh"
this is great ;) thank you very much
~~~~>>>Please always follow rules and read before you post<<<~~~~

Avatar de l’utilisateur
rikardo1979
Messages : 160
Inscription : sam. 09 avr. 2016 08:39
Localisation : UK
Contact :

Re: Moode Audio support?

Message par rikardo1979 » mer. 26 oct. 2016 20:30

just flashed your latest img and testing. So far so good. Great work guys ;)
Much appreciated 8) :wink:
~~~~>>>Please always follow rules and read before you post<<<~~~~

Avatar de l’utilisateur
Conseil Audiophonics
Messages : 143
Inscription : ven. 19 août 2016 08:35
Contact :

Re: Moode Audio support?

Message par Conseil Audiophonics » jeu. 27 oct. 2016 09:20

rikardo1979 a écrit :just flashed your latest img and testing. So far so good. Great work guys ;)
Much appreciated 8) :wink:
You're welcome, don't hesitate if you need :)
Cordialement,
L'équipe Audiophonics.fr

shinzuka
Messages : 78
Inscription : mar. 29 mars 2011 21:40

Re: Moode Audio support?

Message par shinzuka » ven. 28 oct. 2016 22:32

bonsoir,

Open the restart.sh file:
Code :
sudo nano /var/www/commande/restart.sh

C'est normal que le fichier soit vide?

je suis configurer en raspdac v2 j'ai bien fais les modifs dans le fichier Winstar_GraphicOLED.py apres un reboot j'ai rien sur le lcd??

d'avance merci à celui qui répondra
http://redpepper.forumactif.org/" onclick="window.open(this.href);return false;

Avatar de l’utilisateur
Conseil Audiophonics
Messages : 143
Inscription : ven. 19 août 2016 08:35
Contact :

Re: Moode Audio support?

Message par Conseil Audiophonics » mer. 02 nov. 2016 13:44

shinzuka a écrit :bonsoir,

Open the restart.sh file:
Code :
sudo nano /var/www/commande/restart.sh

C'est normal que le fichier soit vide?

je suis configurer en raspdac v2 j'ai bien fais les modifs dans le fichier Winstar_GraphicOLED.py apres un reboot j'ai rien sur le lcd??

d'avance merci à celui qui répondra
Bonjour shinzuka,

En effet, une petite erreur s'est glissée dans notre tuto, il faut enlever le "e" à "commande" dans la ligne de code. Notre message du dessus a été modifié.

Essayez sans le "e" et tout devrait fonctionner :)
Cordialement,
L'équipe Audiophonics.fr

shinzuka
Messages : 78
Inscription : mar. 29 mars 2011 21:40

Re: Moode Audio support?

Message par shinzuka » mar. 08 nov. 2016 19:54

effectivement ça marche mieux sans la petite erreur lol
http://redpepper.forumactif.org/" onclick="window.open(this.href);return false;

Répondre