Forum Audiophonics.fr

Forum du site de vente en ligne Audiophonics.fr : Pour les amateurs de Home Audio, de Connectique et de DIY
Nous sommes actuellement le Mar 23 Oct 2018 17:33

Le fuseau horaire est UTC+1 heure




Publier un nouveau sujet Répondre au sujet  [ 71 message(s) ]  Aller vers la page Précédent  1, 2, 3  Suivant
Auteur Message
Message Publié : Dim 01 Avr 2018 10:49 
Hors-ligne

Inscription : Dim 01 Avr 2018 10:03
Message(s) : 6
apparemment le drag and drop pour installer les plugin a été retiré des dernieres mises à jour.


Haut
 Profil  
 
Message Publié : Dim 01 Avr 2018 11:04 
Hors-ligne

Inscription : Dim 20 Nov 2016 18:54
Message(s) : 65
Effectivement, je viens de constater que ça ne fonctionne plus avec la dernière version.
On trouve une explication sur le forum de Volumio, https://volumio.org/forum/#p45536
Pour installer un plugin non officiel, il faut maintenant le faire en ligne de commande via un terminal SSH.
A moins qu"Audiophonics ne sollicite l'officialisation du plugin auprès du team Volumio ?


Haut
 Profil  
 
Message Publié : Dim 01 Avr 2018 15:38 
Hors-ligne

Inscription : Dim 01 Avr 2018 10:03
Message(s) : 6
Ok, donc entre temps je suis allé sur le lien cité précédemment, j'ai suivi à la lettre les instructions, à savoir download du fichier_kernel dans le répertoire volumio, décompression du fichier et copie de tous les éléments dans un répertoire que j'ai appelé plugin puis j'ai lancé l'installation du plugin ; à l'arrivée il me dit que tout est ok, et effectivement dans volumio j'ai bien le plugin.
Mais le problème, quand j'active le plugin, il me dit qu'il faut redémarrer volumio, ce que je fais, et une fois que volumio est relancé, il me met "I2S DAC" OFF, comme si je n'avais pas activé le ess9028.
J'ai beau recommencer la manip x fois, c'est toujours la même chose.
Par ailleurs, je n'ai plus du tout de son.
:/
Avez vous des idées?

En "type de mixeur" j'ai soit "logiciel" soit "aucun".


Dernière édition par Alexandre le Dim 01 Avr 2018 15:54, édité 1 fois.

Haut
 Profil  
 
Message Publié : Dim 01 Avr 2018 15:53 
Hors-ligne

Inscription : Dim 01 Avr 2018 10:03
Message(s) : 6
En désactivant le plugin et en relançant volumio, il m'affiche le dac cette fois! :)
Mais quand je veux lancer un morceau j'ai le message d'erreur :"Failed to open "alsa" [alsa]; Failed to open ALSA device soft volumu : no such file or directory".
Je précise que j'ai installé le dernier plugin (4.9.65)

Faut-il que je le désinstalle et tente avec le 4.9.51?
est-ce qu'il n'est pas préférable que j'installe une version plus ancienne de volumio? Dans ce cas, jusqu'à quelle version de volumio le kernel 4.9.65 fonctionne t-il svp?


Haut
 Profil  
 
Message Publié : Dim 01 Avr 2018 18:42 
Hors-ligne

Inscription : Dim 20 Nov 2016 18:54
Message(s) : 65
Alexandre a écrit :
Je précise que j'ai installé le dernier plugin (4.9.65)

Le dernier proposé par Audiophonics mais ce n'est pas le dernier compatible Volumio.
Plus haut, j'ai mis un lien vers le 4.9.80

Le 4.9.65 couvre les versions de Volumio 2.344 à 2.368.
Le 4.9.80 couvre les versions de Volumio 2.376 à 2.387.

Le glisser/déposer fonctionne correctement avec le 4.9.80 et Volumio 2.376.
A partir de la 2.378 il n'est plus possible d'installer un plugin par glisser/déposer.


Haut
 Profil  
 
Message Publié : Lun 02 Avr 2018 07:53 
Hors-ligne

Inscription : Dim 01 Avr 2018 10:03
Message(s) : 6
Rebonjour et merci pour vos précieuses indications.
J'ai viré l'ancien plugin, installé le plus récent et ça ne fonctionnait pas. Puis je me suis souvenu d'un de vos posts, ai recommencé l'installation en choisissant la langue anglaise, et cette fois-ci tout fonctionne!
:)
Merci encore pour tout le mal que vous vous êtes donné et pour vos réponses qui furent rapides.
Passez une bonne journée.


Haut
 Profil  
 
Message Publié : Lun 02 Avr 2018 11:18 
Hors-ligne

Inscription : Dim 20 Nov 2016 18:54
Message(s) : 65
Bonjour,
Ci-joint la mise à jour du plugin pour le kernel 4.14.29 utilisé par Volumio 2.389 et ultérieurs.

Comme il n'est plus possible d'installer un plugin non approuvé par le team Volumio depuis l'interface graphique, il faut désormais appliquer la procédure suivante après avoir téléchargé le plugin.

Actions préalables
- désinstaller l'ancien plugin Q2M.
- localiser l'interface de Volumio en anglais.
- procéder à la mise à jour de Volumio vers la version souhaitée.
- redémarrer Volumio


- copier le fichier zip contenant le plugin sous /home/volumio
(sous Linux, depuis le dossier contenant le fichier zip)
Code :
scp Q2M_kernel_4.14.29.zip volumio@volumio.local:/home/volumio


Ouvrir une session SSH dans volumio.
(sous Linux)
Code :
ssh volumio@volumio.local


Dézipper le plugin depuis la ligne de commander Volumio.
Code :
unzip Q2M_kernel_4.14.29.zip


Se placer dans le dossier Q2M nouvellement créé.
Code :
cd Q2M


Installer le plugin.
Code :
volumio plugin install


Redémarrer Volumio.
Code :
reboot


Actions postérieures
- sélectionner le DAC Q2M.
- relocaliser l'interface dans une autre langue que l'anglais, si nécessaire.
- redémarrer Volumio


Pièces jointes :
Description du fichier : Plugin I-Sabre Q2M pour le kernel 4.14.29
Q2M_kernel_4.14.29.zip [34.88 Kio]
Téléchargé 84 fois
Haut
 Profil  
 
Message Publié : Ven 06 Avr 2018 14:48 
Hors-ligne
Administrateur - Site Admin
Avatar de l’utilisateur

Inscription : Mer 26 Juil 2006 12:21
Message(s) : 430
Localisation : Bordeaux
Wow merci beaucoup pour ton soutien Iznogoud. 8)
J'étais en train d'essayer de compiler le driver sur la nouvelle version, mais visiblement il me manquait un truc.

Je vais voir à les mettre en ligne pour qu'on puisse les appeler avec wget ce qui simplifiera l'installation.
Et de toute façon je suis en train de faire un image complète pour les clients que le SSH rebute.


Haut
 Profil  
 
Message Publié : Sam 07 Avr 2018 17:23 
Hors-ligne

Inscription : Dim 20 Nov 2016 18:54
Message(s) : 65
Nicko a écrit :
Je vais voir à les mettre en ligne pour qu'on puisse les appeler avec wget ce qui simplifiera l'installation.
Et de toute façon je suis en train de faire un image complète pour les clients que le SSH rebute.

J'ai envisagé le wget mais ça suppose d'une part un dépôt, d'autre part que le nom de fichier reste constant au fil des versions.
On doit pouvoir lancer un script à travers une commande SSH. Je regarderai quand j'aurai un moment.
A moins qu'Audiophonics ne trouve un terrain d'entente avec le team Volumio pour intégrer le driver nativement.


Haut
 Profil  
 
Message Publié : Lun 09 Avr 2018 10:46 
Hors-ligne
Administrateur - Site Admin
Avatar de l’utilisateur

Inscription : Mer 26 Juil 2006 12:21
Message(s) : 430
Localisation : Bordeaux
Je les ai mis sur le dépôt en zip, on peut au moins les appeler avec wget sur le lien du RAW.

Le plug-in n'est pas la solution idéale car cela demande de le mettre à jour a chaque fois pour suivre le kernel.

Il faudrait que l'overlay soit intégré au kernel général mais je n'ai toujours pas trouvé de partenaire qui pourrait nous proposer cette prestation.


Haut
 Profil  
 
Message Publié : Mar 10 Avr 2018 09:31 
Hors-ligne

Inscription : Dim 20 Nov 2016 18:54
Message(s) : 65
Nicko a écrit :
Il faudrait que l'overlay soit intégré au kernel général mais je n'ai toujours pas trouvé de partenaire qui pourrait nous proposer cette prestation.

La probabilité que les mainteneurs du kernel intègrent d'office le driver pour un chipset si peu répandu, aussi performant soit il, est quasiment nulle.
A mon humble avis, on est condamné au plugin sauf à officialiser le driver auprès du team Volumio. (ce serait d’ailleurs intéressant d'avoir le son de cloche d'Audiophonics sur le sujet par rapport aux sous-entendus que l'on peut lire sur le forum Volumio).


Haut
 Profil  
 
Message Publié : Mar 10 Avr 2018 14:07 
Hors-ligne
Administrateur - Site Admin
Avatar de l’utilisateur

Inscription : Mer 26 Juil 2006 12:21
Message(s) : 430
Localisation : Bordeaux
Concernant ce qu'on peut lire sur ce driver il faut savoir qu'il à évolué dans le temps, et n'est resté disponible dans sa version "répréhensible" que quelques jours, le temps qu'un développeur nous alerte sur le fait que les registres ESS étaient confidentiels et non publiables.

C'est pourquoi nous avons fait refaire ce driver en utilisant des registres génériques.
Un micro contrôleur embarqué sur notre carte s'occupe de lire ces registres pour appliquer les informations comme le volume ou l'entrée au DAC
Le DAC en lui-même est initialisé et configuré par un MCU, lui même épaulé par un CPLD, il ne communique pas avec le RPI.

Ainsi nous sommes en conformité avec le fait de publier le code source, et de ne pas publier les registres confidentiels soumis à NDA.
C'est assez facile à vérifier en regardant les sources.


Haut
 Profil  
 
Message Publié : Lun 23 Avr 2018 12:43 
Hors-ligne

Inscription : Mar 30 Jan 2018 14:22
Message(s) : 3
Thank you Iznogoud for your instructions - they got me most of the way there. I could not manage to copy Q2M_kernel_4.14.29.zip to the folder you specified because windows only shows the boot directory.

Here's how I got the plugin to install using mainly windows operations -
1. Download Q2M_kernel_4.14.29.zip - or whichever one suits the Volumio release you are using. Check this forum page.
2. Unzip Q2M kernel - it will create a folder called "Q2M".
3. Copy the Q2M folder onto your Micro SD flash card under the visible boot directory.
4. Put the flash card back in your RPi and boot it up.
5. Enable SSH if this isn't your first boot - instructions here - https://volumio.github.io/docs/User_Manual/SSH.html
6. SSH to volumio. I used PuTTY. - volumio\volumio.
7. In SSH window:- CD.. ( should take you to "home" )
8. CD.. again.
9. ls - list directories, you should be able to now see "boot".
10. cd boot
11. cd Q2M - the unzipped folder you copied across.
12. without quotes "volumio plugin install"
13. "reboot"

All done.


Haut
 Profil  
 
Message Publié : Mar 24 Avr 2018 13:11 
Hors-ligne

Inscription : Mar 03 Avr 2018 12:09
Message(s) : 18
Je vous remercie pour ces instructions de la mise à jour du plugin du kernel 4.14.29. J'ai galéré un petit au début et j'ai failli même désinstaller mon Volumino car j'ai pensé qu'il y avait de fichiers manquants. Mais j'ai suivi les consignes que Iznogood avait donnés,
et tout est bien qui finit bien :lol:


Haut
 Profil  
 
Message Publié : Ven 18 Mai 2018 09:25 
Hors-ligne

Inscription : Dim 15 Avr 2018 13:16
Message(s) : 3
Installation impeccable en utilisant un mélange des instructions d'Iznogoud et de JLH64.
En résumé :
- téléchargement et décompression du plugin sur mon Mac
- copie du dossier Q2M dans le répertoire /boot de la carte
- remise en place de la carte sur le Raspberry, lancement de Volumio et mise en Anglais
- suivre les instructions de JLH64 à partir de l'étape "6" en ssh
- remettre en Français
- reboot
Il m'a fallu 2 redémarrages pour que la sélection du DAC "audiophonics" soit bien effective.
Ensuite, tout fonctionne, le volume est réglable et le son superbe !

Seul petit bémol, avec le raspberry, lorsque je lis des DSD via mon réseau, j'ai des coupures de son. Les DSD lus à partir d'un DD en USB sont lus sans problème (le souci était identique avec un DAC 9018, donc le 9038 n'est pas en cause).


Haut
 Profil  
 
Message Publié : Ven 18 Mai 2018 12:54 
Hors-ligne

Inscription : Dim 20 Nov 2016 18:54
Message(s) : 65
jfb894 a écrit :
Seul petit bémol, avec le raspberry, lorsque je lis des DSD via mon réseau, j'ai des coupures de son. Les DSD lus à partir d'un DD en USB sont lus sans problème (le souci était identique avec un DAC 9018, donc le 9038 n'est pas en cause).

L'interface ethernet du RPi a un débit plutôt asthmatique. Sans doute la source du problème, sous réserve que le serveur fonctionne correctement et que l'on ne parle pas de WiFi.
Il faudrait essayer avec un RPi3B+ dont l'interface ethernet est plus performante.


Haut
 Profil  
 
Message Publié : Dim 20 Mai 2018 23:46 
Hors-ligne

Inscription : Sam 12 Mai 2018 00:48
Message(s) : 1
i use the ES9028Q2M plugin for this Chinese ES9038Q2M DAC Board, https://www.ebay.com/itm/ES9038-Q2M-DAC-DSD-Decoder-Support-IIS-DSD-384KHz-Coaxial-Fiber-DOP/272844357070?hash=item3f86ca7dce:g:7yUAAOSwu6taZ~Sz, the result is posted here, http://www.diyaudio.com/forums/digital-line-level/322868-chinese-es9038q2m-dac-board-i2s-drive.html, any solutions for native 16/44.1 playback is appreciated.


Haut
 Profil  
 
Message Publié : Ven 25 Mai 2018 09:14 
Hors-ligne
Administrateur - Site Admin
Avatar de l’utilisateur

Inscription : Mer 26 Juil 2006 12:21
Message(s) : 430
Localisation : Bordeaux
This "driver" is only compatible with our board.
The only solution for these cheaps boards is to oversample all data to 24bit.


Haut
 Profil  
 
Message Publié : Ven 25 Mai 2018 09:16 
Hors-ligne
Administrateur - Site Admin
Avatar de l’utilisateur

Inscription : Mer 26 Juil 2006 12:21
Message(s) : 430
Localisation : Bordeaux
jfb894 a écrit :
Seul petit bémol, avec le raspberry, lorsque je lis des DSD via mon réseau, j'ai des coupures de son. Les DSD lus à partir d'un DD en USB sont lus sans problème (le souci était identique avec un DAC 9018, donc le 9038 n'est pas en cause).


Pas de soucis de notre coté même en DSD...

Ça peut également être la source réseau, surtout si c'est en UPNP


Haut
 Profil  
 
Message Publié : Mar 29 Mai 2018 06:01 
Hors-ligne

Inscription : Mar 03 Avr 2018 12:09
Message(s) : 18
Bonjour,
J'ai aussi le même problème avec le drag and drop pour l'installation du plugin. Je rencontre toujours les mêmes options ouvrir ou enregistrer. Je clique sur ouvrir et rien n'est affiché, et le plus plugin n'est pas installé. J'ai essayé maintes fois, et j'ai laissé tomber. Je reste sur l'ancienne version jusqu'à ce que je trouve une solution.


Dernière édition par Mathys le Jeu 06 Sep 2018 16:10, édité 1 fois.

Haut
 Profil  
 
Message Publié : Ven 01 Juin 2018 12:28 
Hors-ligne

Inscription : Dim 20 Nov 2016 18:54
Message(s) : 65
Mathys a écrit :
Bonjour,
J'ai aussi le même problème avec le drag and drop pour l'installation du plugin. Je rencontre toujours les mêmes options ouvrir ou enregistrer. Je clique sur ouvrir et rien n'est affiché, et le plus plugin n'est pas installé. J'ai essayé maintes fois et j'ai laissé tomber. Je reste sur l'ancienne version jusqu'à ce que je trouve une solution.

Une suggestion : lire les posts précédents. La raison pour laquelle l'installation du plugin via l'IHM ne fonctionne plus y est clairement expliquée, de même que la méthode pour contourner le problème.
;)


Haut
 Profil  
 
Message Publié : Sam 02 Juin 2018 20:26 
Hors-ligne

Inscription : Mar 03 Avr 2018 12:09
Message(s) : 18
Bonsoir,
Effectivement j'ai lu les réponses plus hauts et comme vos explications sont claires et détaillées comme d'habitude, je les ai appliquées intégralement pour ne pas avoir encore d'erreurs. Et je vous remercie tous car en ce moment, tout marche bien, plus de problèmes avec Volumio 2. L'installation du plugin s'est bien déroulé :-D Merci merci et adieu drag and drop


Dernière édition par Mathys le Jeu 06 Sep 2018 16:16, édité 1 fois.

Haut
 Profil  
 
Message Publié : Lun 18 Juin 2018 00:39 
Hors-ligne

Inscription : Lun 18 Juin 2018 00:32
Message(s) : 1
Bonjour,
j'ai acheté récemment une carte DAC ES9028Q2M alimentée par un transfo toroïdal, pour mon Pi 3B+ avec la carte Allo Kali.
J'ai fait la procédure d'installation du plug-in pour Volumio mais je n'arrive pas à le faire marcher, notamment sous AirPlay : lorsque je lance un morceau de ma bibliothèque iTunes le son est un mélange du fichier d'origine et d'un bruit blanc horrible. Volumio marche bien en sortie jack classique, aussi avec AirPlay.
Quelqu'un aurait une piste?
Le plug-in est bien à jour? (j'ai la dernière version de Volumio mise à jour hier).


Haut
 Profil  
 
Message Publié : Mer 27 Juin 2018 12:15 
Hors-ligne

Inscription : Mer 27 Juin 2018 12:12
Message(s) : 1
Bonjour,

le driver ES9028Q2M marche bien pour la carte DAC I-Sabre ES9038Q2M mais y a t-il un driver spécifique pour le ES9038Q2M?

Merci


Haut
 Profil  
 
Message Publié : Jeu 28 Juin 2018 11:16 
Hors-ligne
Administrateur - Site Admin
Avatar de l’utilisateur

Inscription : Mer 26 Juil 2006 12:21
Message(s) : 430
Localisation : Bordeaux
Le plugin est fait pour la version 2.389, il n'a pas été recompilé pour la dernière version.

La 2.389 est dispo avec le driver déjà installé ici :
https://mega.nz/#F!gApABIjA!2dm7GPdcqA0tbuGkh2CDGA


Il n'y a pas de driver pour la puce ES9038Q2M en direct, ce n'est pas possible légalement.


Haut
 Profil  
 
Afficher les messages publiés depuis :  Trier par  
Publier un nouveau sujet Répondre au sujet  [ 71 message(s) ]  Aller vers la page Précédent  1, 2, 3  Suivant

Le fuseau horaire est UTC+1 heure


Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité


Vous ne pouvez pas publier de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas insérer de pièces jointes dans ce forum

Recherche de :
Aller vers :  
Propulsé par phpBB® Forum Software © phpBB Group
Traduction et support en français • Utiliser phpBB avec un certificat SSL