rasptouch + digione : squeezelite en erreur

Ici on parle de Raspberry PI, Sparky, Odroid... avec des solutions comme Squeezelite, MPD, Max2Play... ainsi que leur DAC et accessoires dédiés
gangsoleil
Messages : 4
Inscription : jeu. 05 mars 2020 21:14

rasptouch + digione : squeezelite en erreur

Message par gangsoleil » dim. 12 avr. 2020 17:50

Bonjour,

Heureux propriétaire d'un rasptouch digione (acheté chez audiophonics bien sûr), celui-ci fonctionnait très bien jusqu'à il y a encore peu de temps, mais j'ai voulu mettre à jour pcp, et depuis les erreurs s'enchainent, la dernière en date étant que squeezelite ne démarre plus, a priori car il ne trouve plus le driver de la carte !
En effet, dans "output setting" de squeezelite, je ne vois plus sndallodigione, et quoi que je choisisse d'autre, cela ne fonctionne pas !

J'ai essayé beaucoup (trop) de choses jusqu'à présent pour essayer de résoudre ce problème, mais j'en suis toujours au même point.

Est-ce qu'il y aurait un moyen de forcer la réinstallation du driver, ou n'importe quoi d'autre d'ailleurs qui puisse me permettre de refaire fonctionner ce bel appareil ?

Merci !

gangsoleil
Messages : 4
Inscription : jeu. 05 mars 2020 21:14

Re: rasptouch + digione : squeezelite en erreur

Message par gangsoleil » sam. 18 avr. 2020 15:32

Update : ça ne fonctionne toujours pas...

J'ai essayé de faire toutes les mises à jour possibles et imaginables, mais lorsque je choisis "Allo Digione" dans "Audio output device settings" de Squeezelite, alors au redémarrage squeezelite ne démarre pas.
Dans la liste des sorties disponibles, je n'ai que ça :

null
default
plugequal
equal
sysdefault:CARD=ALSA
hw:CARD=ALSA,DEV=0
hw:CARD=ALSA,DEV=1
hw:CARD=ALSA,DEV=2
plughw:CARD=ALSA,DEV=0
plughw:CARD=ALSA,DEV=1
plughw:CARD=ALSA,DEV=2
sysdefault:CARD=DAC
hw:CARD=DAC,DEV=0
plughw:CARD=DAC,DEV=0

Log de démarrage :
Waiting for soundcard sndallodigione to populate......................................... Failed to find sndallodigione (42).
Done (42).

Logs de squeezelite en debug avec la sortie sur allodigione :
/usr/local/bin/squeezelite -n piCorePlayer -o hw:CARD=sndallodigione -a 80:4::1: -d all=debug -f /var/log/pcp_squeezelite.log -v
[17:52:24.914086] stream_init:370 init stream
[17:52:24.914334] stream_init:371 streambuf size: 2097152
[17:52:24.925182] output_init_alsa:939 init output
[17:52:24.925329] output_init_alsa:979 requested alsa_buffer: 80 alsa_period: 4 format: any mmap: 1
[17:52:24.925418] output_init_common:350 outputbuf size: 3528000
[17:52:24.925650] output_init_common:374 idle timeout: 0
[17:52:24.936091] ALSA _snd_pcm_hw_open:1826 Invalid value for card
[17:52:24.936225] test_open:281 playback open error: No such device
[17:52:24.936288] output_init_common:391 unable to open output device: hw:CARD=sndallodigione



Je suis preneur de toutes les idées :)

gangsoleil
Messages : 4
Inscription : jeu. 05 mars 2020 21:14

Re: rasptouch + digione : squeezelite en erreur

Message par gangsoleil » dim. 26 avr. 2020 14:21

Bon, pour finir, j'ai réinstallé PCP avec la procédure d'audiophonics, viewtopic.php?f=12&t=1756 , et ça marche à nouveau.

Merci au support d'audiophonics, et bonnes écoutes à tou·te·s

Répondre