Ampli HiFI hybride USB

Vous aimez bricoler ? N'hésitez pas à nous présenter vos réalisations DIY ;)

Modérateur : Audiophonics

Technosvitman
Messages : 17
Inscription : sam. 27 déc. 2014 17:06

Ampli HiFI hybride USB

Message par Technosvitman » dim. 28 déc. 2014 21:30

Bonjour à toutes et à tous,

Je propose ici mon projet d'amplificateur hybride USB.

Il s'agit d'un assemblage de plusieurs cartes :

1 ) Puissance :

AUDIOPHONICS APD86 MKII Amplificateur Stéréo LM3886 2x68W

2 ) Carte codec, qui fait office de contrôle de volume d'une part et de
DAC :

EVKIT MAX9867

3) Carte de contrôle et d'interfaçage USB :

EFM32GG-STK3700

Cet ampli fonctionneras sous deux mode :
1 ) Voie analogique : utilisation des entrées RCA, le codec audio ne sert que de contrôleur de volume
2 ) Voie numérique : utilisation de l'ampli comme carte son USB, le codec audio est utilisé en tant que DAC
à partir du flux audio récupéré par le microcontrôleur EFM32.

Le programmes de contrôle dans sa première version supportant le premier mode et est validé.

Je posterais d'ici peu de nouvelles photos sur la finition mécanique pour cette première version.

La partie USB viendra dans une seconde version avec l'ajout de la connectique en façade.

Bonne journée à toutes et à tous!
Pièces jointes
puissance.JPG
Première phase d'assemblage avec la partie puissance + alimentations
puissance.JPG (58.84 Kio) Consulté 2317 fois
input_control.JPG
Assemblage temporaire codec et contrôle en fonctionnement
input_control.JPG (45.99 Kio) Consulté 2317 fois
input_control_cards.JPG
Cartes codec et carte de contrôle
input_control_cards.JPG (31.51 Kio) Consulté 2317 fois

Technosvitman
Messages : 17
Inscription : sam. 27 déc. 2014 17:06

Re: Ampli HiFI hybride USB

Message par Technosvitman » dim. 03 mai 2015 10:13

Bonjour à toutes et à tous,

voici un petit point sur l'avancement du projet. Aujourd'hui, l'ampli possède toutes les fonctions de contrôle pour la première version :

- Réglage du volume
- Fonction "Mute"
- Fonction "Hold" (limiteur de volume)

D'un point de vue mécanique il manque des petites tiges pour accéder aux boutons poussoirs,
probablement en plexis pour pouvoir les illuminer de bleue via des leds.

Au point de vue électronique et électrique il manque :
- Un nettoyage du câblage :
* Le secteur (une erreur de perçage de la façade me contraint à recâbler)
* La connexion entre le codec audio et l'entrée de l'étage de puissance
* La nappe d'interfaçage numérique entre la carte de contrôle et la carte codec.
- Une interconnexion entre la carte de contrôle et l'étage de puissance afin de s'assurer que ce dernier soit près (les relais actifs).
Cela me permettra d'afficher "Init" tant que l'étage de puissance n'a pas activé ses relais de sortie.

Ceci dit, il fonctionne déjà impeccablement. Le problème de perçage m'a ajouté évidemment
un ronflement côté gauche du fait de la proximité du secteur. Cela n'existait pas dans le câblage original.
Pièces jointes
back_small.JPG
L'arrière
back_small.JPG (30.52 Kio) Consulté 1962 fois
into_the_box_v1_small.JPG
Dans le boitier (il faut faire le ménage!)
into_the_box_v1_small.JPG (46.46 Kio) Consulté 1962 fois
front_without_buttons_small.JPG
La façade
front_without_buttons_small.JPG (31.47 Kio) Consulté 1962 fois

Avatar de l’utilisateur
Audiophonics
Messages : 996
Inscription : lun. 24 janv. 2011 12:55

Re: Ampli HiFI hybride USB

Message par Audiophonics » lun. 04 mai 2015 11:02

Bonjour,

et merci de nous faire partager votre réalisation.

Nous lirons avec intérêt la suite de vos avancées.
David

Technosvitman
Messages : 17
Inscription : sam. 27 déc. 2014 17:06

Re: Ampli HiFI hybride USB

Message par Technosvitman » mer. 06 mai 2015 22:08

Bonjour à toutes et à tous,

Un peu de nettoyage vient d'être fait et j'ai procédé à l'ajout d'un retour d'état de l'étage de puissance.

Pour ce faire, j'ai utilisé un photo-resistance que j'ai couplé au moyen d'une gaine thermo-rétractable à la Led de status de l'étage de puissance.

L'écran affiche maintenant "- Init -" tant que l'étage n'est pas près.

Merci pour le soutien!
Pièces jointes
into_the_box_v2_small.JPG
Du nettoyage !
into_the_box_v2_small.JPG (41.64 Kio) Consulté 1922 fois
power_relay_led_small.JPG
Led de status
power_relay_led_small.JPG (45.44 Kio) Consulté 1922 fois

Technosvitman
Messages : 17
Inscription : sam. 27 déc. 2014 17:06

Re: Ampli HiFI hybride USB

Message par Technosvitman » jeu. 07 mai 2015 19:47

Bonjour à toutes et à tous,

voici les screenshots de l'ampli avec le petit gecko (en référence au nom de la famille de microcontrôleur que j'ai utilisé) qui clignote pour signaler que le programme tourne bien.

L'écran d'initialisation affiche un décompte pour laisser le temps à l'étage de puissance de monter en charge.
Si ce dernier est prêt avant la fin du décompte, la carte de contrôle passe sans attendre dans son état de fonctionnement normal.

A bientôt!
Pièces jointes
screen_init_small.JPG
Initialisation avec le compteur
screen_init_small.JPG (30.81 Kio) Consulté 1899 fois
screen_vol_small.JPG
Affichage du volume
screen_vol_small.JPG (30.19 Kio) Consulté 1899 fois
screen_mute_small.JPG
La fonction "mute"
screen_mute_small.JPG (28.74 Kio) Consulté 1899 fois

Technosvitman
Messages : 17
Inscription : sam. 27 déc. 2014 17:06

Re: Ampli HiFI hybride USB

Message par Technosvitman » dim. 10 mai 2015 16:17

Bonjour à toutes et à tous,

j'apporte une légère modification non négligeable à cette première version de mon ampli.

Voici la problématique :

En cours de fonctionnement l'ampli redémarre pour une raison quelconque (micro-coupure edf, redémarrage volontaire). Il en résulte que l'étage de puissance active ses sorties avant même que le codec audio ne soit initialisé. Un bruit très désagréable se fait entendre (brrrrr, plop). Ce bruit est normal étant donné la phase de réinitialisation de la configuration du codec.

Résolution du problème :

J'ai tout simplement ajouté un petit module relais Arduino, commandé par ma carte de contrôle, pour piloter le primaire du transfo dédié à l'étage de puissance.

Dorénavant, l'ampli procède à la séquence d'allumage suivante :

1) Initialisation du codec.
2) Allumage du relais de pilotage du transformateur
3) Attente d'activation des relais de sortie de l'étage de puissance

Plus aucun bruit ne se fait entendre!

Bon dimanche!!!

Technosvitman
Messages : 17
Inscription : sam. 27 déc. 2014 17:06

Re: Ampli HiFI hybride USB

Message par Technosvitman » mer. 13 mai 2015 12:49

Bonjour à toutes et à tous,

comme on dit : un bon schéma vaut mieux qu'un long discours!

Bientôt : la finition de la façade, la finition du nettoyage du câblage (sur le schéma, la connexion line out) et une petite vidéo de présentation.

Bonne journée!
Pièces jointes
ampli.png
Architecture générale
ampli.png (26.27 Kio) Consulté 1839 fois

Technosvitman
Messages : 17
Inscription : sam. 27 déc. 2014 17:06

Re: Ampli HiFI hybride USB

Message par Technosvitman » sam. 16 mai 2015 18:50

Bonjour à toutes et à tous,

J'annonce la finalisation de la version 1 de ce projet.

J'attends vos remarques et vos questions :)

Bonne soirée!
Pièces jointes
front_v3_small.JPG
front_v3_small.JPG (31.15 Kio) Consulté 1806 fois
into_the_box_v3_small.JPG
into_the_box_v3_small.JPG (42.97 Kio) Consulté 1806 fois

Répondre