Page 1 sur 1

Ampli HiFI hybride USB

Publié : dim. 28 déc. 2014 21:30
par Technosvitman
Bonjour à toutes et à tous,

Je propose ici mon projet d'amplificateur hybride USB.

Il s'agit d'un assemblage de plusieurs cartes :

1 ) Puissance :

AUDIOPHONICS APD86 MKII Amplificateur Stéréo LM3886 2x68W

2 ) Carte codec, qui fait office de contrôle de volume d'une part et de
DAC :

EVKIT MAX9867

3) Carte de contrôle et d'interfaçage USB :

EFM32GG-STK3700

Cet ampli fonctionneras sous deux mode :
1 ) Voie analogique : utilisation des entrées RCA, le codec audio ne sert que de contrôleur de volume
2 ) Voie numérique : utilisation de l'ampli comme carte son USB, le codec audio est utilisé en tant que DAC
à partir du flux audio récupéré par le microcontrôleur EFM32.

Le programmes de contrôle dans sa première version supportant le premier mode et est validé.

Je posterais d'ici peu de nouvelles photos sur la finition mécanique pour cette première version.

La partie USB viendra dans une seconde version avec l'ajout de la connectique en façade.

Bonne journée à toutes et à tous!

Re: Ampli HiFI hybride USB

Publié : dim. 03 mai 2015 10:13
par Technosvitman
Bonjour à toutes et à tous,

voici un petit point sur l'avancement du projet. Aujourd'hui, l'ampli possède toutes les fonctions de contrôle pour la première version :

- Réglage du volume
- Fonction "Mute"
- Fonction "Hold" (limiteur de volume)

D'un point de vue mécanique il manque des petites tiges pour accéder aux boutons poussoirs,
probablement en plexis pour pouvoir les illuminer de bleue via des leds.

Au point de vue électronique et électrique il manque :
- Un nettoyage du câblage :
* Le secteur (une erreur de perçage de la façade me contraint à recâbler)
* La connexion entre le codec audio et l'entrée de l'étage de puissance
* La nappe d'interfaçage numérique entre la carte de contrôle et la carte codec.
- Une interconnexion entre la carte de contrôle et l'étage de puissance afin de s'assurer que ce dernier soit près (les relais actifs).
Cela me permettra d'afficher "Init" tant que l'étage de puissance n'a pas activé ses relais de sortie.

Ceci dit, il fonctionne déjà impeccablement. Le problème de perçage m'a ajouté évidemment
un ronflement côté gauche du fait de la proximité du secteur. Cela n'existait pas dans le câblage original.

Re: Ampli HiFI hybride USB

Publié : lun. 04 mai 2015 11:02
par Audiophonics
Bonjour,

et merci de nous faire partager votre réalisation.

Nous lirons avec intérêt la suite de vos avancées.

Re: Ampli HiFI hybride USB

Publié : mer. 06 mai 2015 22:08
par Technosvitman
Bonjour à toutes et à tous,

Un peu de nettoyage vient d'être fait et j'ai procédé à l'ajout d'un retour d'état de l'étage de puissance.

Pour ce faire, j'ai utilisé un photo-resistance que j'ai couplé au moyen d'une gaine thermo-rétractable à la Led de status de l'étage de puissance.

L'écran affiche maintenant "- Init -" tant que l'étage n'est pas près.

Merci pour le soutien!

Re: Ampli HiFI hybride USB

Publié : jeu. 07 mai 2015 19:47
par Technosvitman
Bonjour à toutes et à tous,

voici les screenshots de l'ampli avec le petit gecko (en référence au nom de la famille de microcontrôleur que j'ai utilisé) qui clignote pour signaler que le programme tourne bien.

L'écran d'initialisation affiche un décompte pour laisser le temps à l'étage de puissance de monter en charge.
Si ce dernier est prêt avant la fin du décompte, la carte de contrôle passe sans attendre dans son état de fonctionnement normal.

A bientôt!

Re: Ampli HiFI hybride USB

Publié : dim. 10 mai 2015 16:17
par Technosvitman
Bonjour à toutes et à tous,

j'apporte une légère modification non négligeable à cette première version de mon ampli.

Voici la problématique :

En cours de fonctionnement l'ampli redémarre pour une raison quelconque (micro-coupure edf, redémarrage volontaire). Il en résulte que l'étage de puissance active ses sorties avant même que le codec audio ne soit initialisé. Un bruit très désagréable se fait entendre (brrrrr, plop). Ce bruit est normal étant donné la phase de réinitialisation de la configuration du codec.

Résolution du problème :

J'ai tout simplement ajouté un petit module relais Arduino, commandé par ma carte de contrôle, pour piloter le primaire du transfo dédié à l'étage de puissance.

Dorénavant, l'ampli procède à la séquence d'allumage suivante :

1) Initialisation du codec.
2) Allumage du relais de pilotage du transformateur
3) Attente d'activation des relais de sortie de l'étage de puissance

Plus aucun bruit ne se fait entendre!

Bon dimanche!!!

Re: Ampli HiFI hybride USB

Publié : mer. 13 mai 2015 12:49
par Technosvitman
Bonjour à toutes et à tous,

comme on dit : un bon schéma vaut mieux qu'un long discours!

Bientôt : la finition de la façade, la finition du nettoyage du câblage (sur le schéma, la connexion line out) et une petite vidéo de présentation.

Bonne journée!

Re: Ampli HiFI hybride USB

Publié : sam. 16 mai 2015 18:50
par Technosvitman
Bonjour à toutes et à tous,

J'annonce la finalisation de la version 1 de ce projet.

J'attends vos remarques et vos questions :)

Bonne soirée!