Branchement plusieurs dac i2s

Ici on parle d’électronique, donc composants, modules amplificateurs, DAC, préampli, softstart...
ttoorrxx
Messages : 4
Inscription : jeu. 21 nov. 2013 01:39

Branchement plusieurs dac i2s

Message par ttoorrxx » sam. 05 juil. 2014 12:04

Bonjour à tous,

Je souhaite faire un préampli homecinema 6 canaux avec un USBstreamer : http://www.minidsp.com/products/usb-aud ... sbstreamer

et 3 modules dac audiophonics : http://www.audiophonics.fr/audiophonics ... -8396.html

Chaque dac est branché en i2s sur l'USBstreamer en parallèle (type bus et non en étoile)...

MCLK, SCLK, GND, LRCLK sont donc partagés entre les dacs de cette façon :

MCLK USBstreamer -> MCLK dac 1,
MCLK dac 1 -> MCLK dac 2,
MCLK dac 2 -> MCLK dac 3.

Idem pour SCLK, GND, LRCLK...

Puis USBstreamer Data1&2 -> data dac 1,
USBstreamer Data2&3 -> data dac 2,
USBstreamer Data3&4 -> data dac 3.

L'USBstreamer est alimenté par l'usb du pc, et les dacs par une alimentation à découpage +5v 10A.


Je rencontre cependant un petit souci lorsque plusieurs dacs sont alimentés.
Aucun son ne sort...

Alors que si un seul est alimenté (dac2 par exemple), j'obtiens bien en sortie du dac le son qui correspond aux canaux 3&4 de l'USBstreamer...

ça sent la grosse bétise mais la je sèche!
Si quelqu'un a déjà fais ce genre de montage ou voit d'où provient l'erreur je suis preneur !!!

Merci de m'avoir lu !

Avatar de l’utilisateur
Lioneldu66
Messages : 182
Inscription : sam. 22 mars 2014 00:28
Localisation : 66

Re: Branchement plusieurs dac i2s

Message par Lioneldu66 » lun. 28 juil. 2014 21:56

Bonsoir.

Pour faire les essais vous avez utilisé un film avec un bande son 5.1 ?

ttoorrxx
Messages : 4
Inscription : jeu. 21 nov. 2013 01:39

Re: Branchement plusieurs dac i2s

Message par ttoorrxx » mar. 29 juil. 2014 06:37

Bonjour,

OUPS, j'ai oublié de faire un retour depuis que le problème est résolu...
Il semblerait que le partage de la MCLK posait problème.
Je ne me sert donc plus du MCLK de l'usbstreamer mais de l'horloge interne de chaque dac.
Je ne comprends pas pourquoi mais cela fonctionne maintenant.
Merci à Audiophonics pour leur aide rapide, ils ont apparemment fait face a ce problème auparavant.

Pour les test, ils ont étés effectués sur des flms en 5.1 et surtout à l'aide du pilote audio windows pour carte son multicanal qui permet de sortir un son sur le canal voulu exclusivement...

Merci !

Répondre