Page 1 sur 1

Player à base de RPI3+Kali: distortion

Publié : dim. 11 mars 2018 00:44
par monosoX
Bonjour,
J'ai reçu il y a 2 jours ma commande Audiophonics afin de monter un petit player hifi.
J'avais déjà un Raspberry Pi3.

J'ai commencé à me monter une alimentation à base de
- un transfo R-core
Image
- et un module
Image
Avec mon multimètre j'ajuste la tension continue de sortie à 9V qui va alimenter le module d'alimentation pour raspberry (accepte en entrée 7 à 12V, ajusté en sortie à 5,1V pour le plus avoir le petit "éclair" sur ma sortie écran HDMI).

En parallèle je monte en sandwich sur mon RPI3 le reclocker Kali et enfin par dessus le dac à base de ES9028Q2M.

La solution logicielle est un classique volumio dans sa version stable (2.368 à ce jour).

Le câblage mis en oeuvre est celui qui est présenté au bas de la page article du DAC:
Image

- Une sortie 5V du module ATX vient directement alimenter le Kali via les pin sur le côté (marqué pour tests internes ?).
- les 3 câbles pour trigger les GPIO.

Volumio fonctionne bien, je le pilote avec un téléphone android. Jusque là tout va bien.
Je configure dans "Lecture" un DAC générique ou RPI3. J'ai essayé toutes les combinaisons en bas de cette page pour les différentes possibilités de suréchantillonages.

Mais je suis confronté à 2 problèmes:

1) le son est horriblement saturé et distordu ! Le seul son exploitable que je suis arrivé à en tirer aura été en retirant le Kali de ce montage. Vu les retours très positifs qu'on peut lire sur ce composant je pense qu'il y a soit un problème avec celui que j'ai reçu, soit une étape que j'ai loupé.
Je suis un peu à cours d'idées. J'ai installé une autre distribution Rune audio, le comportement est exactement le même.

2) le module de gestion "façon ATX" ne lance pas de séquence de shutdown. J'utilise un bouton poussoir avec led intégrée acheté ici même il y a des années (similaire à celui-ci).
Image

Une pression lance le boot.
La LED s'allume mais clignote régulièrement en permanence et ne revient jamais fixe.
Une pression modérée entre 1 et 3 secondes n'a pas d'effet.
Au delà de 4 secondes le courant se coupe comme attendu.

Donc je voudrais avoir votre sentiment sur ces deux petits soucis avant d'éventuellement faire appel au SAV s'il s'avère qu'il y a un soucis hardware.
Merci par avance de votre aide.

Re: Player à base de RPI3+Kali: distortion

Publié : dim. 11 mars 2018 00:50
par monosoX
Parmi mes quelques recherches (d'autres ont été confrontés au même problème) voici des indices:

Allo Kali crackles:

cf http://www.diyaudio.com/forums/digital- ... 27998.html :
I then changed the sampling rates to 16bit/* -> crackle dint go away, changed it to 24bit/* -> no change. Then I just thought let me change the rate to 24 bit & 192Khz and...it was GONE !!

http://www.diyaudio.com/forums/digital- ... 16204.html :
The crackling was still there, no change. If I revert to the standard WaveIO-DDDAC setup without the Kali, the crackling goes away. This might mean something is wrong with the Kali/setup, but I am not totally convinced.

http://www.diyaudio.com/forums/digital- ... 27998.html :
My understanding is that the crackle is due to the bit rates transferred to the DDDAC and that I was not able to set it up properly via the mpd.conf file in Volumio.

Alors, problème de soudures ? de mise en oeuvre ? niveau logiciel ?

Re: Player à base de RPI3+Kali: distortion

Publié : lun. 12 mars 2018 10:51
par monosoX
Je tiens à remercier le SAV audiophonics qui m'a répondu très vite (mail), et ce avec des réponses précises et pertinentes.
Je note ici mes avancées pour ceux qui pourraient être confrontés aux mêmes questions.

### plugin DAC ###
J'ai utilisé jusque là les drivers par défaut embarqués dans volumio (v2.368 stable), à savoir "Generic I2S DAC" ou "R-PI DAC".
Pour la puce sabre 9028 qui équipe son dac audiophonics mets à disposition son plugin sur son repo github.
Le module actuel est fait pour le kernel 4.9.65.
Il faut activer ssh pour se connecter à son raspberry avec le user "volumio". Puis comme indiqué :

Code : Tout sélectionner

git clone https://github.com/audiophonics/Volumio2_I-sabre9028_plugin.git
cd Volumio2_I-sabre9028_plugin/
volumio plugin install
Après un reboot vous verrez apparaître dans la liste des DACs "Audiophonics I-sabre ES9028Q2M".


### module d'alimentation ###
Une pression sur le bouton ne triggait rien. Il faut savoir qu'ils déclenchent un script associé. Il y a donc une petite mise en place à faire au préalable.
(lire la page du forum aurait solutionné mon problème, RTFM !)
Dans mon cas j'ai suivi cette page qui solutionne mon problème parfaitement.

### kali ###
Reste le problème encore inexpliqué du son dégueul*sse qui sort de ce Kali est qui très certainement défectueux. Je vais voir avec le SAV pour faire un échange.