Afficheur Winstar OLED non fonctionnel sur RaspDAC

Ici on parle d’électronique, donc composants, modules amplificateurs, DAC, préampli, softstart...
5030SDEC
Messages : 3
Inscription : mer. 03 août 2016 10:27

Afficheur Winstar OLED non fonctionnel sur RaspDAC

Message par 5030SDEC » sam. 08 sept. 2018 18:10

J'ai depuis 2 ans maintenant un RaspDAC I-Sabre à base de Raspberry 3. Je pense que c'est la génération 1 mais sans certitude.
Je n'avais pas encore pris le temps de configurer l'affichage et je suis actuellement incapable de le faire fonctionner, quelque soit le script utilisé.
Je suis actuellement sous PCP et j'ai testé le script sur https://github.com/dhrone/Raspdac-Display ainsi que le script original qui était sur viewtopic.php?f=4&t=1492 (16x2_oled_volumio.py)

2 photos de mon câblage sont en pièces jointes.

Je soupçonne que l'écran soit HS mais avant d'en commander un nouveau j'aimerais un peu d'aide. J'ai l'impression que je n'ai pas de chance car mon premier DAC USB n'est plus reconnu non plus...

J'ai testé avec des LED les sorties RS / E / D4 à D7 avec succès.

Une idée pour m'affranchir définitivement du problème d'écran ? Quelqu'un peut-il me confirmer le câblage ?

Merci de votre aide.

Cyril
Pièces jointes
DSC08569.JPG
Câblage 2
DSC08569.JPG (216.43 Kio) Consulté 304 fois
DSC08568.JPG
Câblage 1
DSC08568.JPG (228.6 Kio) Consulté 304 fois

Avatar de l’utilisateur
Cram28
Messages : 62
Inscription : dim. 29 nov. 2015 13:41

Re: Afficheur Winstar OLED non fonctionnel sur RaspDAC

Message par Cram28 » sam. 08 sept. 2018 22:42

Bonsoir Cyril,

(ouf, ça fait longtemps que je n'étais pas venu sur le forum !)

Et donc c'est vieux... ;)

Sur ce même - long - sujet que vous pointez, il y a au moins deux "zones d'échanges" qui causent câblage:
- viewtopic.php?f=12&t=1492&start=100#p6228" onclick="window.open(this.href);return false;
- viewtopic.php?f=12&t=1492&start=150#p7516" onclick="window.open(this.href);return false;

j'ai eu pour ma part un problème de masse non raccordée, mais il n'y a pas de "tresse" sur mon modèle (un des premiers, des fils unitaires): les câbles de la tresse sont passants ?

Votre photo semble pas mal proche du premier lien...
Qu'utilisez-vous comme solution de diffusion: Volumio, RuneAudio, autre ?
Dans la solution que vous avez récupérée de Dhrone, le fichier Winstar_GraphicOLED.py contient vers le début [lignes ~6x) la définition des raccordement GPIO - Winstar_GraphicOLED. Comment c'est valorisé ?

Code : Tout sélectionner

# Make sure to set your pin mappings to the correct wiring for your display!!

# Pin Mappings V2
#OLED_DB4=25
#OLED_DB5=24
#OLED_DB6=23
#OLED_DB7=15
#OLED_RS=7
#OLED_E=8

# Pin Mappings V3
OLED_DB4=25
OLED_DB5=24
OLED_DB6=23
OLED_DB7=27
OLED_RS=7
OLED_E=8
Cà vaut le coup d'essayer l'un ou l'autre en commentant/dé-commentant les lignes (#)

Vous dîtes:
[...]Je suis actuellement sous PCP et [...]
Pardon, ça veut dire quoi "PCP" ?

Merci.
ps: juste des pistes, l'écran est peut-être mort quand-même ...

5030SDEC
Messages : 3
Inscription : mer. 03 août 2016 10:27

Re: Afficheur Winstar OLED non fonctionnel sur RaspDAC

Message par 5030SDEC » lun. 10 sept. 2018 18:35

Bonsoir,

@Cram28 : "PCP" = PiCorePlayer, que je conseille à tous...
J'ai bien changé l'affectation des lignes OLED_D7 (que ce soit 15 ou 27 ça ne change rien d'ailleurs...)

Sur le premier lien que vous indiquez, une personne a dû câblé toutes les pin du LCD (bien qu'il soit indiqué le contraire et que le script fasse bien fonctionner l'écran en 4 bits). Quelqu'un peut-il le confirmer ?

J'ai vérifié l'ensemble des fils des 2 tresses : ils sont tous passants.

Cyril

Répondre