Forum Audiophonics.fr

Forum du site de vente en ligne Audiophonics.fr : Pour les amateurs de Home Audio, de Connectique et de DIY
Nous sommes actuellement le Jeu 23 Nov 2017 15:56

Le fuseau horaire est UTC+1 heure




Publier un nouveau sujet Répondre au sujet  [ 4 message(s) ] 
Auteur Message
Message Publié : Mar 04 Avr 2017 12:26 
Hors-ligne

Inscription : Lun 03 Avr 2017 07:48
Message(s) : 6
Hello.

First, I want to apologize about my English.

A few days ago, I bought a es9018k2m DAC. This one:

http://www.audiophonics.fr/fr/dac-diy/a ... 11500.html

It sounds nicely with a 24bits FLAC file. But there is no way to bit play perfect 16bits files, not resampled. But the sync scrip doesn’t work. Well really the scrip works. I can see the ‘commands’ using a serial interface and a terminal emulator. But DAC doesn’t change play mode. It remains in 24bits. Playing only noise and some sounds.

I’ve tested the work modes:

In Mode Slave 1, the DAC works fine, always in 24bits mode. It is not an option for me, I want to play 16bits music without resampling. No display.

In Mode Standalone 2, DAC work in 16bits or 24bits, sound is nice, but I need to change working mode manually. Display works and show sampling rate.

Finally, in Mode Serial Hardware, DAC works only in 24bits mode. With 16bits music, shows the audiophonics logo. The script is sending the working mode and volume information through serial connection, but DAC doesn’t change it’s working mode.

My primary objective is run DAC in Mode Serial Hardware for automatically change between 16bits and 24-32bits. And obviously play 16bits and 24 bits in a bit perfect way.

Any ideas about how can I solve this issue?

Thank you in advance.


Haut
 Profil  
 
Message Publié : Mar 04 Avr 2017 13:40 
Hors-ligne
Administrateur - Site Admin
Avatar de l’utilisateur

Inscription : Mer 26 Juil 2006 12:21
Message(s) : 403
Localisation : Bordeaux
Hi,

If show only Audiophonics logo in mode 3, it look like that the DAC do not receive the serial script...
What release are you using ? The serial port must be released in order to get serial connection on serial pins.


Haut
 Profil  
 
Message Publié : Mer 05 Avr 2017 07:11 
Hors-ligne

Inscription : Lun 03 Avr 2017 07:48
Message(s) : 6
Hi,

Correct, seems as a DAC doesn’t receive the serial information. But if wire from microcontroller is disconnected and a serial adapter is connected at pin 8 I can see the instructions sent by the script at the start of a song.

I’m currently using last version of RuneAudio modified by you.

I’m not sure about ‘release the serial port’. But I can see commands in a terminal using a serial adapter.

Results are the same using a Raspberry PI 2 or a Raspberry PI 3. And /boot/cmdline.txt doesn’t contain ‘console=ttyAMA0,115200 kgdboc=ttyAMA0,115200’.

Kind regards.


Haut
 Profil  
 
Message Publié : Mar 11 Avr 2017 07:51 
Hors-ligne

Inscription : Lun 03 Avr 2017 07:48
Message(s) : 6
Really it seems that my unit is faulty. After a lot of testing with 2 different Raspberrys, one two and one three, and different Rune audio images, one provided by Audiophonics and other original from Runeaudio and manually modified with the scripts, none of them seems to work.

As explained before I can see data from Raspberry to the DAC. But nothing happens, no change to 16 bits mode and no volume change with 24 bit files.

So now I’m looking how to return the DAC to Audiophonics for fix it.

Kind regards.


Haut
 Profil  
 
Afficher les messages publiés depuis :  Trier par  
Publier un nouveau sujet Répondre au sujet  [ 4 message(s) ] 

Le fuseau horaire est UTC+1 heure


Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité


Vous ne pouvez pas publier de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas insérer de pièces jointes dans ce forum

Recherche de :
Aller vers :  
Propulsé par phpBB® Forum Software © phpBB Group
Traduction et support en français • Utiliser phpBB avec un certificat SSL