Forum Audiophonics.fr

Forum du site de vente en ligne Audiophonics.fr : Pour les amateurs de Home Audio, de Connectique et de DIY
Nous sommes actuellement le Mar 18 Sep 2018 18:48

Le fuseau horaire est UTC+1 heure




Publier un nouveau sujet Répondre au sujet  [ 3 message(s) ] 
Auteur Message
Message Publié : Sam 08 Sep 2018 18:10 
Hors-ligne

Inscription : Mer 03 Août 2016 10:27
Message(s) : 3
J'ai depuis 2 ans maintenant un RaspDAC I-Sabre à base de Raspberry 3. Je pense que c'est la génération 1 mais sans certitude.
Je n'avais pas encore pris le temps de configurer l'affichage et je suis actuellement incapable de le faire fonctionner, quelque soit le script utilisé.
Je suis actuellement sous PCP et j'ai testé le script sur https://github.com/dhrone/Raspdac-Display ainsi que le script original qui était sur http://forum.audiophonics.fr/viewtopic.php?f=4&t=1492 (16x2_oled_volumio.py)

2 photos de mon câblage sont en pièces jointes.

Je soupçonne que l'écran soit HS mais avant d'en commander un nouveau j'aimerais un peu d'aide. J'ai l'impression que je n'ai pas de chance car mon premier DAC USB n'est plus reconnu non plus...

J'ai testé avec des LED les sorties RS / E / D4 à D7 avec succès.

Une idée pour m'affranchir définitivement du problème d'écran ? Quelqu'un peut-il me confirmer le câblage ?

Merci de votre aide.

Cyril


Pièces jointes :
Description du fichier : Câblage 2
DSC08569.JPG
DSC08569.JPG [ 216.43 Kio | Consulté 124 fois ]
Description du fichier : Câblage 1
DSC08568.JPG
DSC08568.JPG [ 228.6 Kio | Consulté 124 fois ]
Haut
 Profil  
 
Message Publié : Sam 08 Sep 2018 22:42 
Hors-ligne
Avatar de l’utilisateur

Inscription : Dim 29 Nov 2015 13:41
Message(s) : 62
Bonsoir Cyril,

(ouf, ça fait longtemps que je n'étais pas venu sur le forum !)

Et donc c'est vieux... ;)

Sur ce même - long - sujet que vous pointez, il y a au moins deux "zones d'échanges" qui causent câblage:
- viewtopic.php?f=12&t=1492&start=100#p6228
- viewtopic.php?f=12&t=1492&start=150#p7516

j'ai eu pour ma part un problème de masse non raccordée, mais il n'y a pas de "tresse" sur mon modèle (un des premiers, des fils unitaires): les câbles de la tresse sont passants ?

Votre photo semble pas mal proche du premier lien...
Qu'utilisez-vous comme solution de diffusion: Volumio, RuneAudio, autre ?
Dans la solution que vous avez récupérée de Dhrone, le fichier Winstar_GraphicOLED.py contient vers le début [lignes ~6x) la définition des raccordement GPIO - Winstar_GraphicOLED. Comment c'est valorisé ?
Code :
# Make sure to set your pin mappings to the correct wiring for your display!!

# Pin Mappings V2
#OLED_DB4=25
#OLED_DB5=24
#OLED_DB6=23
#OLED_DB7=15
#OLED_RS=7
#OLED_E=8

# Pin Mappings V3
OLED_DB4=25
OLED_DB5=24
OLED_DB6=23
OLED_DB7=27
OLED_RS=7
OLED_E=8


Cà vaut le coup d'essayer l'un ou l'autre en commentant/dé-commentant les lignes (#)

Vous dîtes:
Citer :
[...]Je suis actuellement sous PCP et [...]

Pardon, ça veut dire quoi "PCP" ?

Merci.
ps: juste des pistes, l'écran est peut-être mort quand-même ...


Haut
 Profil  
 
Message Publié : Lun 10 Sep 2018 18:35 
Hors-ligne

Inscription : Mer 03 Août 2016 10:27
Message(s) : 3
Bonsoir,

@Cram28 : "PCP" = PiCorePlayer, que je conseille à tous...
J'ai bien changé l'affectation des lignes OLED_D7 (que ce soit 15 ou 27 ça ne change rien d'ailleurs...)

Sur le premier lien que vous indiquez, une personne a dû câblé toutes les pin du LCD (bien qu'il soit indiqué le contraire et que le script fasse bien fonctionner l'écran en 4 bits). Quelqu'un peut-il le confirmer ?

J'ai vérifié l'ensemble des fils des 2 tresses : ils sont tous passants.

Cyril


Haut
 Profil  
 
Afficher les messages publiés depuis :  Trier par  
Publier un nouveau sujet Répondre au sujet  [ 3 message(s) ] 

Le fuseau horaire est UTC+1 heure


Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité


Vous ne pouvez pas publier de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas insérer de pièces jointes dans ce forum

Recherche de :
Aller vers :  
Propulsé par phpBB® Forum Software © phpBB Group
Traduction et support en français • Utiliser phpBB avec un certificat SSL